Page 1 of 1

.NET 4.0 Support

PostPosted: Wed May 09, 2012 8:29 pm
by robbm
Is there any way to load AddIns written with .NET 4.0? It appears to just skip over my library. I'm really just guessing at the cause though.

Re: .NET 4.0 Support

PostPosted: Thu May 10, 2012 5:26 am
by ian
The current release of DataSlave is built using .NET 3.5.

However can I suggest that you send your code to support to have a look. Please indicate if this is a per-sales enquiry or if you have purchased the SDK. If the latter then please include in your email your premium support number provided with delivery of the SDK.

Re: .NET 4.0 Support

PostPosted: Thu May 10, 2012 3:14 pm
by robbm
The dependencies needed for the code to function go pretty deep, so I don't think that's viable. Can you verify whether the DataSlave MapEditor can load an AddIn written for .NET 4.0?

Re: .NET 4.0 Support

PostPosted: Fri May 11, 2012 11:07 am
by ian
Our recommendation is that you use .NET 3.5.

However if you can email support with details we can schedule to investigate further.